Authentication Issue
Incident Report for FutureFeed
Resolved
An internal maintenance issue was identified and resolved.
Posted Dec 14, 2022 - 08:29 EST
Investigating
We are currently experiencing issues with third-party authentication process. We are looking into the matter and will provide updates here as we have them.
Posted Dec 14, 2022 - 08:17 EST
This incident affected: FutureFeed.co.